SSL_verify_mode of SSL_VERIFY_NONE for client is depreciated!

Si vous rencontrez le message d’erreur SSL_verify_mode of SSL_VERIFY_NONE for client is depreciated, la première chose à réaliser est de faire un export comme ceci :

export PERL_LWP_SSL_VERIFY_HOSTNAME=0

Si le problème n’est pas résolu, il est possible que ce soit dû à la version de libwww-perl utilisé, dans ce cas, on prendra soin de downgrader la version utilisée.

Pour se faire on utilisera la commande cpan :

cpan> i /libwww-perl/

Distribution GAAS/libwww-perl-5.837.tar.gz
Distribution GAAS/libwww-perl-6.01.tar.gz
Distribution GAAS/libwww-perl-6.04.tar.gz
Author LWWWP (« The libwww-perl mailing list » <libwww@perl.org>)
4 items found

cpan> install GAAS/libwww-perl-5.837.tar.gz

Et voilà, si tout est OK, vous ne devriez plus avoir le message d’erreur.

Le message d’erreur dans son intégralité est :

Using the default of SSL_verify_mode of SSL_VERIFY_NONE for client
 is deprecated! Please set SSL_verify_mode to SSL_VERIFY_PEER
 together with SSL_ca_file|SSL_ca_path for verification.
 If you really don't want to verify the certificate and keep the
 connection open to Man-In-The-Middle attacks please set
 SSL_verify_mode explicitly to SSL_VERIFY_NONE in your application.
*******************************************************************
 at /usr/lib/perl5/site_perl/5.12.3/LWP/Protocol/http.pm line 31

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.